Incorrect workout removed timeline items


I mistakenly inported a workout that was a recorded 29 day walk workout. I’m not sure if that came from my watch or something. After importing such, it shows only that for those days which is about the last month.

Is there any current way or maybe future to remove such and go back to the old confirmed data? Such included various other correctly imported workouts. Hope it can be repaired.

Yep! Tap the “Edit” button on the details view for that item, and it’ll take you back to the workout add/remove view.

Once you tap the “Remove workout from timeline” button, it’ll put back all the previous timeline data.

When workouts are added to the timeline, the existing data isn’t deleted, it’s just marked “disabled”. So it’s always there, ready to be put back, if you change your mind.

I often do this when I’m wanting to feel out whether some workout data is better than the data Arc recorded itself. It’s not always obvious from what’s shown on the previous map and import view. Sometimes it’s easier to add it in properly and play around with it, to get a proper sense of it, then remove it again if you don’t like it.

Oh you can also get to that add/remove workout view from the “x workouts” red button at the top left of timeline view. Though if it’s a workout that spans 29 days… you’d have to find the first day of the workout, because it’d be listed under that day’s workouts, I think.

Thank you very much Matt. Worked great.

I forgot what happened when I tried the edit button. Maybe it was doing some background tasks and from what I recall, it seemed non-responsive. Finding the first day of the workout, and removing, the button also seemed to show the UI response of being tapped without any other feedback. I’d guess perhaps there were many days to change, it took some time and maybe how the UI is such as without showing any progress indicator, you might not have thought of as the time it takes to change so many days is something that might not happen often.

Yep, I think you’re right. In my testing I probably didn’t run into a case where it took long enough to justify a loading spinner or progress bar. But a workout that covered that many days would certainly justify!

Glad to hear it fixed it though :smile:

Aside: The problem that got you into that mess in the first place is one that’s still on my todos.

Workouts and Workout Routes are stored separately in HealthKit / Health app, and they can sometimes not correctly match up. For example the workout might have start and end times that don’t match the workout route’s start and end times. And the workout route might contain location samples that also fall outside of the stated ranges.

After first releasing the workout importer I found a couple of cases where those inconsistencies could cause problems, and fixed them. But it still sometimes appears, so there’s clearly at least one more case that I haven’t caught yet. I’m betting your mystery 29 day workout fell into that trap. Though 29 days is certainly much more extreme than anything I’ve seen so far! I typically see the routes slip outside of the ranges by seconds or minutes, or at most maybe an hour.

Anyway, hopefully I’ll stumble onto the cause of that one before it happens again!

If it helps, of the two workouts that I think might have been responsible and started around that time, I had done them with Zones app. I haven’t used such in a while. Not sure what the Health app shows, yet in Fitness, it shows them as ordinary walks around an hour each but for some reason the time zone is incorrect.

Ah yeah, timezones come into it too sometimes. Technical detail: Dates and times in iOS aren’t stored with timezones attached - the timezone needs to be stored separately. So in HealthKit it’s possible to add data without timezone attached, which can create all sorts of messes!

It’s been particularly troublesome for my other app, This & That, which has to collate totals or averages per day, but without explicit timezones for data it can easily end up in the wrong day totals.

Yeah, I suspect this comes down to the Fitness app showing the start/end/duration based on the Workout’s info, which might not match the Workout Route’s info. You’ll likely see a similar thing in Arc’s workout import view, with the workouts showing correct duration, start, end in the first view, but potentially showing a different duration once you import it and go to the detail view for it.

Though I’ve already got Arc constraining the imported workouts to the dates/times specified in the Workout, so it shouldn’t be possible for the Workout Route to mess it up. But… clearly it can still happen somehow.