Huge Data Gap while traveling by train

Yesterday I took the train from Munich to Zurich. On my last two train journeys it worked fine, yet this time there is a large data gap between the last known position and the destination. What seems to be the matter here?

Hi @Kyoji!

It’s likely that iOS terminated the app, which stops the recording. Then eventually iOS restarted the app automatically later on. Basically iOS is a major pest and can’t be trusted to leave the app alone to do its thing.

The easiest workaround for avoiding this kind of situation is to install Arc Mini (Arc Mini 1.0 is live on the App Store!), and add Mini’s Current Item widget to one of your home screens.

What that achieves is having two Arc recorders available to do the job, so that if one of them gets terminated, the other will notice within a couple of minutes, and take over the job. It doesn’t result in any higher battery consumption, because only one of them will ever be recording at a time, so the other one sits in standby using no energy until it’s needed.

In practice this workaround gets rid of almost all data gap situations. (Though it’s still not a 100% fix, because iOS really is supremely untrustworthy when it comes to leaving apps alone to do their jobs, and there is still risk that it’ll kill off both apps on the odd occasion).

The Current Item widget has little red/green dots on the bottom right, which indicate the alive/dead state of the two apps. So if you see two green dots, both apps are alive and ready to do their job. Red means dead. Left dot = Arc App, right dot = Arc Mini.