Migration to new iphone - restoring failed


I move my arc app to new iPhone (14pro). After transfer data (direct, phone to phone with apple mechanism) I notice that my ARC app is empty.
There are backup files on iCloud, but there is no data in app.
How to import old data to new iPhone? Maybe is there the other way to restore data?

Best regards,

Hi @gaber!

Unfortunately this is a somewhat common problem with migrations to new phones, regardless of whether setting up the new phone with direct transfer from old, or restoring it from an iCloud backup.

Because Arc has a very large amount of data (several gigabytes), it doesn’t finish transferring/restoring fast enough, and iOS for some reason allows you to open the app before the data is there. Then if Arc is opened without the data available, it will think it’s been freshly installed, and will create a new empty database. Really not what we want!

Fortunately if you had Arc’s own iCloud Drive Backups turned on, you can restore from those. Arc should have seen the Backups folder on first launch, prepared it for restore, and offered to do so with a pink bar at the top of the timeline view. But if that didn’t appear, we can still get the restore going.

What you need to do is copy (not move!) the “Backup” folder into the “Import” folder in Arc App’s iCloud Drive folder. From there, if you want to use the simple “managed restore” system, which does it all for you, rename that folder to “Restore”, so that you have a Restore folder inside the Import folder. Then Arc will see that folder, and offer to begin the managed restore.

Alternatively you can skip the folder rename, and go into Arc’s Settings tab → Backup, Import & Export, then open the File Importer view. Once in that view, you can tap “Import All” on the Sample Files, Note Files, and Day Summary Files sections, and each file will begin importing.


I have a somewhat similar restore problem question. I’ve got data from 2013 to the present (the first part of that was from my Moves export when you added that as a feature), I recently had to restore my phone and there is a gap of data between July 2018 and March 2023. In the Arc App cloud folder, the Backups folder contains 2013-W11, which was the beginning of the data, and goes up to 2018-W27 and then does not resume again until 2023-W12. All of the missing weeks are in the Previous Backups folder, but I can’t seem to move these files into the restore folder successfully. Do you need to do a clean restore to start everything over again? Is there a way to merge the Backups and Previous Backups data so that everything can be restored as it was? I have looked elsewhere on the support forum and can’t find the answer… Any words of wisdom would be much appreciated.

Thank you,


Hi @Sbell!

You can drop any backup files into the Import folder, and the File Importer view (from Settings tab → Backup, Import & Export), will see them and allow you to import them.

Though there is one caveat: the files you put in the Import folder need to also be in a folder named by the object type, same as they are in the Backups folder. So for example the sample files need to be in “Import/LocomotionSamples”, the notes files in “Import/Notes”, etc.

The easiest way forward I think would be to just copy your entire Previous Backups folder into the Import folder, such that you’ve got “Import/Previous Backups/LocomotionSamples” etc. That will get all the necessary dependent files in there, ready to be used if the importer thinks it needs them. Then in the File Importer view you can scroll down the Sample Files list and find the appropriate weeks to import, then tap on those weeks.

The importer will then automatically pick up any Timeline Item files and Place files it needs, as dependents of the Sample files. You don’t need to manually import Timeline Item or Place files, just the Sample files. The importer will take care of the rest.

For Note files and Day Summary files, you can manually import those. The Note files being especially important, if you add notes to timeline items! The Day Summary files aren’t very important - they basically only contain information about whether you tapped “favourite” on a day or not.

Thank you. And this should be done after erasing and reinstalling the app?

I recommend doing this in your current install of the app. No need to reinstall. The File Importer will allow you to import data into the gaps where data is currently missing.

I try to import data from backup. The App is frozen or import failed.
I have c.a. 180k timeline items files.

Hi @gaber!

Note that you don’t need to tap Import on the Timeline Item files. Those are automatically imported as needed, when you tap on the Sample files.

For the Sample files in your screenshot, I see an info icon on the right indicating there was some error. If you tap on that icon it should open up a details view, which will help us to figure out what’s going wrong. Could you post a screenshot of one of those details views? Thanks!


I have finally, I think, successfully restored ten years of data. It took me almost two weeks. There seemed to be various timeline item or associated files that were corrupted, e.g., said that I was walking for months, which were too big to be corrected without crashing the app. A few times before a crash I could open the erroneous activity description and it would contain hundreds of data points that seemed to include days / weeks of various activities all lumped into the same place. I had my regular backup and two or three previous backups, all of which I put into the arc restore file and then downloaded local on my phone via icloud drive. It took a long time to find where the corruption was, but I finally pinpointed it and then did not include the files of the weeks when it happened and did not included the weeks before and after just to be safe. Because the corruption would cause a crash, I would have to uninstall the app every time and then start over again. Sometimes I knew that a week was corrupted, but would accidentally touch the wrong timeline file and would have to start over again. The timeline items with multiple entries for the same week I just included the first instance and ignored the rest, which seemed to work fine. Also, when I clicked a red exclamation point and then tried again with the missing dependencies, which were all missing place names, that worked to restore the data of that week too, even though the timeline item file had the grey circle and not the check mark. I think that I have finally solved it. I avoided the corrupt files and then went day by day to make sure that the app registered each day without snagging up or crashing. So I have everything working again with various gaps in the timeline from where I did not restore the corrupted weeks. I am now waiting for the backup of the new clean data set. When I get a new phone and have to get my data onto it will the new backup contain the “clean” version that I have recreated and then I will be able to get a good restore just from that, or will I also need to include the earlier backup files, which will break the app again? Also, in doing this, I though that it might have been easier if there was a way to delete timeline and associate files within the app, rather than having to start over again if the wrong files were included. In other words, being able to delete entire days within the interface and/or being able to delete bad weeks from the timeline from within the backup file list. I just wanted to share my experience with all of this. There were times when I almost gave up but I persevered.

1 Like

Yes, you can just use that one new clean backup folder, and can ignore the previous ones.

Thanks Matt and all for all the help here and elsewhere. I was able to import old data and merge such that i have all my Arc app data in one place.

There were errors with Summaries. I’m not sure what was meant by replies of such; no relation to confirmed places? Then perhaps it doesn’t matter.

Of the error, last saved nil, could i edit the JSON files to allow them to import correctly? Perhaps I’d feel better knowing its all there.

That’s a curious error for the day summary import. It doesn’t quite make sense to me, but then I haven’t looked at the backup restore code in a long while.

Anyway, I absolutely wouldn’t worry about it! The only thing the day summaries contain that’s of any use is whether you “favourited” the day or not. Everything else in them is just statistics that are auto calculated anyway, so no need to have restored.

So if everything else came in correctly, then you’re all good!

Yes I believe everything else came in correctly. I had trouble with manual import with many files consistently not imported, despite downloading them with Files, but with an error but moving them into ./Import/Restore for managed restore and all went through ok.

1 Like

One final thing. Some folders didn’t complete in restore and left remaining files. Any need for concern? Apologies haven’t reread thread and forgot how they relate

Nope, that’s all good! The import process will pick out files it needs from the Place and TimelineItem folders, and skip any files in there that it doesn’t need. The files it doesn’t need will typically be timeline items that have been deleted, and places that were used at some stage but now aren’t.

The TimelineRangeSummary folder contains the files that basically are only used to know whether you tapped “favourite” on a day or not. If you do want that extra detail restored, you can tap “Import All” on the “Day Summary Files” section in the File Importer. Though the File Importer won’t actually delete imported files (only the automatic/managed restore process does that), so I’m guessing you’ve already imported those files and they’re just left over because the File Importer left them as-is.

Great. Thank you very much.

1 Like