Inconsistent track

For the second time in the past month I have a nonsensical track where an individual segment has a far longer timespan than the track that contains it. With the last one I tried to fix it but the day’s record ended up merged into a single track which took ages to split into the correct stops and journeys.

In this case I have a 1:20 walk with a 10:24 walking segment inside it. That segment looks correct apart from a massive fictional swerve back to my home about 15 miles away.

What might have caused this and what can I do to resolve it?

Hah! Yeah, that clearly doesn’t make sense.

My first guess is it’s a memory caching problem. Back in Arc’s early years I chose to have Arc store a lot of information in memory, and not check the database to see whether it’s still correct, in order to keep energy / battery use as low as possible.

Back then it was almost a necessity, to make it possible to do all-day, high detail timeline recording. These days, with newer phones, thankfully it’s not! Anyway, that shortcut saves battery but sometimes causes the in-memory cache to fall out of sync with what’s in the database, creating situations where what you see in the app is potentially nonsense, and also not what’s actually been stored.

So the first thing I try when I see timeline weirdness is swiping the app closed. Once it’s relaunched it has to fetch all that data from the database again, so the incorrect stuff cached in memory won’t be a problem anymore.

If the mess is still there after that… then you have to start fiddling about with segment splitting etc. In this case I can’t make sense of that 10 hour walking segment - it’s just super weird! So I’m not sure what I’d do. Perhaps I’d try just splitting a few samples off one end of it, changing them to stationary, and seeing what that does.

Aside: All these kinds of bugs are getting solved wholesale, with the work I’m doing on rebuilding Arc Timeline in the new Arc Timeline Editor app. The new app (and new LocoKit2, underlying recording/processing engine) no longer uses these kinds of dodgy caching shortcuts, because that level of extreme energy efficiency isn’t needed anymore. That means that whole classes of weird bugs just disappear. Yay! Hopefully I’ll have a beta of Arc Timeline Editor ready mid month, if all goes well.

1 Like

Thanks, I also encounter this more often now, and I would appreciate a fix soon…

Cheers, Bernd


Thank you, this is the second time I’ve experience recently. When I tried to fix it previously, I ended up with a single segment for the entire day which I then laboriously split. This time it was pain free and resolved manually quite easily.

A second issue I’m finding is lots of days popping up over the past couple of years needing an item confirmed whereas there were previously none. I’d guess 90% of these were my two ‘home’ locations where I’d expect a high level of confidence. Do you have any idea why this changed?

In case it helps, here’s another example of it getting into an odd state with non-sequential sections. Both contain valid segments despite them having overlapping timespans.

Since I stopped using Arc Mini and switched to Arc Recorder instead, I occasionally experience track/time span overlaps. So I have to confirm the correct segment of each track for Arc to merge them.

Yep, it’ll be the new LocoKit2 engine in Arc Recorder. Because it’s a ground up rewrite of LocoKit (that’s still used in Arc Timeline app), it does a bunch of things subtly differently. And that means, with the two apps using different recording engines, there’s sometimes weird clashes and miscommunications.

Several of those I’ve got my eye on, and can fix up and smooth out soon, with hopefully not too much fuss. Though the proper fix will be to migrate Arc Timeline over to LocoKit2 as its underlying recording engine. That’s not something I’ll be doing for a while yet though, as it’ll be a major migration! I’ll probably end up running Arc Timeline on old LocoKit for many more months, until LocoKit2 is fully fleshed out and ready to take over the job completely.

@midor Yeah it’s definitely worsened with the switch to Arc Recorder, due to the LocoKit2 reasons. I’m going to get out a couple of minor updates to Arc Timeline and Arc Recorder over the next couple of weeks, to smooth out the worst of it.

I’d hoped to get the updates out sooner, but I’m currently on a week trip in Japan, taking my mum around Osaka and Hiroshima, so haven’t had any time online. Just trying to catch up on a bunch of things on a day off today! I should be back to work proper next Wednesday.

Thank you for your update on this matter. The bug is annoying, but not a problem we can’t deal with the more or less normal amount of daily timeline confirmations for now.

So please enjoy your time with your mom. Family is more important than this app.

1 Like