Delay on new FourSquare locations being available in Arc?

I often create missing public locations in FourSquare and, historically, after a few hours they are available in Arc. I’ve recently (a few days ago) created some missing locations in FourSquare and they’re still not available in Arc. Are you aware of such an issue?
Saracen Car Park - Saracen Place - Saracen Car Park - Penryn, Cornwall is an example of such a location.

Thanks in anticipation!

Hi @gsoper!

This would presumably be due to Foursquare’s moderation system. When you add a new place in one of their apps you can use it immediately in their app, but it won’t be available publicly so anyone else (or any other apps) for some period of time. It will be “pending moderation”.

Though why it would start taking much longer than it used to, I don’t know. That does seem odd. It’s probably worth asking Foursquare themselves about that. They’re the only ones who will know for sure.

I submitted a support request and the following was their response:

Hello there,
Thank you for reaching out.

We’re here to help, but in order to do that we need a bit more information from you. Can you give us an example of the venue page that is not visible on another platform?

Also, kindly note that partner apps only take a small number of places that are in the Foursquare place database. This is based on a few factors:

The business page has to have a full and completed address
The business page has to have a certain number of check-ins
The business page has been in Foursquare’s place database for a certain amount of time

Unfortunately, we do not have any insight into other platforms’ business let alone can we influence their actions. If things have not yet been updated on Arc App, it’s possible you may need to contact Arc App support, because it may be a bug-related issue on the Arc App, that we at Foursquare are not able to fix.

For more references please check the following help center article: Jira Service Management.

I look forward to your reply.

Best regards,

I also notice someone else experiencing this issue at New foursquare locations don’t populate

In my case, I’d say I’ve only been seeing this for month or so…

1 Like

Oh I added an address and hours let’s see if the show shows up in a week

Ok yeah it shows up now after I added an address that’s stupid, the old database didn’t require such detailed information as

I agree @Hutima, that’s stupid, and is a regression from their previously better service.

I’ve also seen Arc’s Foursquare bill spike dramatically this month, so it’s now Arc’s biggest expense by far - something like five times the next biggest expense. So I’ll be having words with Foursquare again about the general decline in database quality and API service, given it’s currently costing a lot more while providing lower quality.

In case it helps, here’s a list of places I’ve added to FourSquare within recent weeks and are still not showing in Arc App:

Historically, such additions have shown up in an hour or two…

Yeah that’s been my experience in the past too. So this new behaviour is definitely a regression.

All those places look like they have at least some basic address attached? So they don’t seem to fit the pattern the Foursquare rep described. Hmm. Unless more than one person has to have checked in. In which case it’s useless - we can’t work like that. We need newly added places to be available to the person who added them!

I’ve put in a developer support request for it. Along with some angry words. Foursquare have also overcharged me to the tune of almost 1000 USD over the past two months. So unless there’s some very good explanation (or refund/credit), and some satisfying answers to the various regressions in database and service quality, I’ll be looking to test some competing services next month.